且构网

分享程序员开发的那些事...
且构网 - 分享程序员编程开发的那些事

数据结构实验之查找一:二叉排序树

更新时间:2022-03-22 22:03:38

数据结构实验之查找一:二叉排序树

Time Limit: 400MS Memory Limit: 65536KB

Problem Description

对应给定的一个序列可以唯一确定一棵二叉排序树。然而,一棵给定的二叉排序树却可以由多种不同的序列得到。例如分别按照序列{3,1,4}和{3,4,1}插入初始为空的二叉排序树,都得到一样的结果。你的任务书对于输入的各种序列,判断它们是否能生成一样的二叉排序树。

Input

输入包含若干组测试数据。每组数据的第1行给出两个正整数N (n < = 10)和L,分别是输入序列的元素个数和需要比较的序列个数。第2行给出N个以空格分隔的正整数,作为初始插入序列生成一颗二叉排序树。随后L行,每行给出N个元素,属于L个需要检查的序列。
简单起见,我们保证每个插入序列都是1到N的一个排列。当读到N为0时,标志输入结束,这组数据不要处理。

Output

对每一组需要检查的序列,如果其生成的二叉排序树跟初始序列生成的二叉排序树一样,则输出"Yes",否则输出"No"。

Example Input

4 2
3 1 4 2
3 4 1 2
3 2 4 1
2 1
2 1
1 2
0

Example Output

Yes
No
No

Code realization

#include <iostream>
using namespace std;
struct node
{
	int data;
	struct node *left,*right;
};
void creat(node *&root,int num)
{
	if(root == NULL)
	{
		root = new node;
		root->data = num;
		root->left = NULL;
		root->right = NULL;
	}
	else
	{
		if(num > root->data)
			creat(root->right,num);
		else
			creat(root->left,num);
	}
}
int compare(node *&root1,node *&root2)
{
	if(root1==NULL && root2==NULL)
		return 1;
	else if(root1->data == root2->data)
		return compare(root1->left,root2->left)&&compare(root1->right,root2->right);
	else
		return 0;
}
int main()
{
	
	int n,l;
	while(cin>>n)
	{
		node *root1,*root2;
		if(n==0)
			break;
		else
		{
			root1 = NULL;
			cin>>l;
			int i;
			for(i=0;i<n;i++)
			{
				int a;
				cin>>a;
				creat(root1,a);
			}
			while(l--)
			{
				root2=NULL;
				for(i=0;i<n;i++)
				{
					int a;
					cin>>a ;
					creat(root2,a);
				}
				if(compare(root1,root2))
					cout<<"Yes"<<endl;
				else
					cout<<"No"<<endl;
			}
		}

	}
	return 0;
}