且构网

分享程序员开发的那些事...
且构网 - 分享程序员编程开发的那些事

1031. Hello World for U (20)

更新时间:2022-02-11 19:18:03

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor

简析:一次ac,不解释。

#include <iostream>
using namespace std;

int main(int argc, const char * argv[]) {
    string s;
    cin >> s;
    int len = (int)s.length();
    int n1, n2, n3, i = 0;
    n1 = n3 = (len + 2) / 3;
    n2 = len - n1 * 2 + 2;
    
    for (i = 0; i < n1 - 1; i++) {
        for (int j = 0; j < n2; j++) {
            if (j == 0) {
                printf("%c", s[i]);
            }else if(j == n2 - 1){
                printf("%c\n", s[len - i - 1]);
            }else{
                printf(" ");
            }
        }
    }
    int t = i;
    for (; i < t + n2; i++) {
        printf("%c", s[i]);
    }
    printf("\n");
    
    return 0;
}