且构网

分享程序员开发的那些事...
且构网 - 分享程序员编程开发的那些事

B-POJ-3278 Catch That Cow

更新时间:2021-11-24 00:01:11

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long
does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

经典的BFS题目,每次3种选择

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
int flag[100001];
void BFS(int N,int K){
    queue<int> a;
    int b;
    a.push(N);
    while(!a.empty()){
        b=a.front();
        a.pop();
        if(b==K){
            printf("%d",flag[b]);
            return;
        }
        if(b+1<=100000&&flag[b+1]==0){
            flag[b+1]=flag[b]+1;
            a.push(b+1);
        }
        if(b-1>=0&&flag[b-1]==0){
            flag[b-1]=flag[b]+1;
            a.push(b-1);
        }
        if(2*b<=100000&&flag[2*b]==0){
            flag[2*b]=flag[b]+1;
            a.push(2*b);
        }
        if(b-1<0||2*b>100000||b+1>100000)
            continue;
        //开始将pop放在这里导致进死循环。。
    }
    return;
}
int main(){
    int N,K;
    memset(flag,0,sizeof(flag));
    scanf("%d%d",&N,&K);
    if(N<K)
        BFS(N,K);
    else
        printf("%d",N-K);
    return 0;
}

题目很简单,但开始没注意pop的位置,找了一晚上。。