且构网

分享程序员开发的那些事...
且构网 - 分享程序员编程开发的那些事

E-POJ-3087 Shuffle'm Up

更新时间:2021-11-24 00:00:59

POJ-3087

Description
A common pastime for poker players at a poker table is to shuffle stacks of chips. Shuffling chips is performed by starting with two stacks of poker chips, S1 and S2, each stack containing C chips. Each stack may contain chips of several different colors.

The actual shuffle operation is performed by interleaving a chip from S1 with a chip from S2 as shown below for C = 5:

E-POJ-3087 Shuffle'm Up
The single resultant stack, S12, contains 2 * C chips. The bottommost chip of S12 is the bottommost chip from S2. On top of that chip, is the bottommost chip from S1. The interleaving process continues taking the 2nd chip from the bottom of S2 and placing that on S12, followed by the 2nd chip from the bottom of S1 and so on until the topmost chip from S1 is placed on top of S12.

After the shuffle operation, S12 is split into 2 new stacks by taking the bottommost C chips from S12 to form a new S1 and the topmost C chips from S12 to form a new S2. The shuffle operation may then be repeated to form a new S12.

For this problem, you will write a program to determine if a particular resultant stack S12 can be formed by shuffling two stacks some number of times.

Input
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of four lines of input. The first line of a dataset specifies an integer C, (1 ≤ C ≤ 100) which is the number of chips in each initial stack (S1 and S2). The second line of each dataset specifies the colors of each of the C chips in stack S1, starting with the bottommost chip. The third line of each dataset specifies the colors of each of the C chips in stack S2 starting with the bottommost chip. Colors are expressed as a single uppercase letter (A through H). There are no blanks or separators between the chip colors. The fourth line of each dataset contains 2 * C uppercase letters (A through H), representing the colors of the desired result of the shuffling of S1 and S2 zero or more times. The bottommost chip’s color is specified first.

Output
Output for each dataset consists of a single line that displays the dataset number (1 though N), a space, and an integer value which is the minimum number of shuffle operations required to get the desired resultant stack. If the desired result can not be reached using the input for the dataset, display the value negative 1 (−1) for the number of shuffle operations.

Sample Input
2
4
AHAH
HAHA
HHAAAAHH
3
CDE
CDE
EEDDCC

Sample Output
1 2
2 -1

网上都是模拟,可以看成单向搜索,重复就跳出来,感觉和模拟没啥不同

// 0MS 764KB
#include<iostream>
#include<cstdio>
#include<queue>
#include<string>
#include<map>
using namespace std;
string s1,s2,s12;
int C;
struct Node{
    string cur;
    int step;
};
string Do(string &s1,string &s2){
    string now;
    for(int i=0;i<C;i++){
        now+=s2[i];
        now+=s1[i];
    }
    return now;
}
void BFS(string s1,string s2,string s12){
    map<string,bool>vis;     //来标记出现过的情况
    queue<Node>Q;
    Node now,next;
    now.step=1;
    now.cur=Do(s1,s2);
    vis[now.cur]=true;
    Q.push(now);
    while(!Q.empty()){
        now=Q.front();
        Q.pop();
        if(now.cur==s12){
            printf("%d\n",now.step);
            return;
        }
        s1.clear();s2.clear();   //开始没清空
        for(int i=0;i<C;i++)
            s1+=now.cur[i];
        for(int i=C;i<2*C;i++)
            s2+=now.cur[i];
        next.cur=Do(s1,s2);
        if(!vis[next.cur]){
            next.step=now.step+1;
            vis[next.cur]=true;
            Q.push(next);
        }
    }
    printf("-1\n");
}
int main(){
    int N,flag=1;
    scanf("%d",&N);
    while(N--){
        cin>>C;
        cin>>s1>>s2>>s12;
        printf("%d ",flag);
        flag++;
        BFS(s1,s2,s12);
    }
    return 0;
}

原本用的模拟过的,不过听学长说可以广搜过,写这的时候就写了个,结果bug找半天没找出来,只好找大佬帮忙了。发现又是没有清空数据。。。