且构网

分享程序员开发的那些事...
且构网 - 分享程序员编程开发的那些事

算法学习之路|PAT Ranking

更新时间:2022-02-17 23:26:07

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
解题思路:
每个考场有若干的考生,共有n个考场,要求将学生按照分数大小从高到底排序,并按要求输出信息。
定义一个结构体来存储每个学生的信息,包括考场排名和总排名。

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct stu{
    long long id;
    int grade,ln,lr,gr;
};

bool cmp(stu a,stu b){
    if(a.grade!=b.grade)return a.grade>b.grade;
    else{
        return a.id<b.id;
    }
}
int main(){
    int n;
    scanf("%d",&n);
    int m;
    vector<stu>fin;
    for(int i=0;i<n;i++){
        scanf("%d",&m);
        vector<stu>tem(m);
        for(int j=0;j<m;j++){
            scanf("%lld %d",&tem[j].id,&tem[j].grade);
            tem[j].ln=i+1;
        }
        sort(tem.begin(),tem.end(),cmp);
        tem[0].lr=1;
        fin.push_back(tem[0]);
        for(int j=1;j<m;j++){
            tem[j].lr=j+1;
            if(tem[j].grade==tem[j-1].grade){
                tem[j].lr=tem[j-1].lr;
            }
            fin.push_back(tem[j]);
        }
    }
    sort(fin.begin(),fin.end(),cmp);
    fin[0].gr=1;
    for(int i=1;i<fin.size();i++){
        fin[i].gr=i+1;
        if(fin[i].grade==fin[i-1].grade){
            fin[i].gr=fin[i-1].gr;
        }
    }
    printf("%d\n",fin.size());
    for(int i=0;i<fin.size();i++){
        printf("%013lld %d %d %d\n",fin[i].id,fin[i].gr,fin[i].ln,fin[i].lr); 
    }
    return 0;
}